Follow

What are the system requirements for creating a blog book with Blog2Print?

You can use Blog2Print on any of these supported web browsers: Firefox, Chrome, Internet Explorer and Safari. We suggest using the latest version.

You'll also need Adobe Reader to view a sample blog book and to preview the final version of your book. You can download the free software now by clicking here.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk